• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Unable to take heap dump, when exceuting this command(jmap -heap:format=b <process id of jboss>)

 
Santosh Kumar Balasubramani
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When exceuting this below command for the heap dump, following is the exception.

jmap -heap:format=b <process id of jboss> --> Command

Attaching to process ID 26788, please wait...
sun.jvm.hotspot.debugger.NoSuchSymbolException: Could not find symbol "gHotSpotVMTypeEntryTypeNameOffset" in any of the known library names (libjvm.so, libjvm_g.so, gamma_g)
at sun.jvm.hotspot.HotSpotTypeDataBase.lookupInProcess(HotSpotTypeDataBase.java:400)
at sun.jvm.hotspot.HotSpotTypeDataBase.getLongValueFromProcess(HotSpotTypeDataBase.java:381)
at sun.jvm.hotspot.HotSpotTypeDataBase.readVMTypes(HotSpotTypeDataBase.java:86)
at sun.jvm.hotspot.HotSpotTypeDataBase.<init>(HotSpotTypeDataBase.java:68)
at sun.jvm.hotspot.bugspot.BugSpotAgent.setupVM(BugSpotAgent.java:550)
at sun.jvm.hotspot.bugspot.BugSpotAgent.go(BugSpotAgent.java:476)
at sun.jvm.hotspot.bugspot.BugSpotAgent.attach(BugSpotAgent.java:314)
at sun.jvm.hotspot.tools.Tool.start(Tool.java:146)
at sun.jvm.hotspot.tools.JMap.main(JMap.java:126)
Debugger attached successfully.
jmap requires a java VM process/core!

 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What operating system? (I suspect a version of Linux...) Which version of the JVM is running JBoss AS? (Run "$JAVA_HOME/bin/java -version" and post the result.) Is the jmap utility from the same version of the JVM?
 
Ifteqar Ahmed
Ranch Hand
Posts: 85
Java Linux MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Team,

Please Provide the complete details before posting Any Problems here....
 
Santosh Kumar Balasubramani
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Below is the mentioned java version.

java version "1.5.0_14"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_14-b03)
Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_14-b03, mixed mode)
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You still didn't answer the first question.

Also look at the result of running:

$JAVA_HOME/bin/java -version

Also run this:

ps -ef | grep java > javaprocs.txt

and post the contents of javaprocs.txt

Also attach the server/xxx/log/boot.log file to your reply.

What I am suspecting is that you are not running JBoss AS with the JVM whose version output you posted.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic