• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
  • Knute Snortum
Sheriffs:
  • Liutauras Vilda
  • Tim Cooke
  • Junilu Lacar
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Joe Ess
  • salvin francis
  • fred rosenberger

my first application its not available

 
Ranch Hand
Posts: 48
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi guys,,
i got a problem so i'm using netbeans 7.0, richfaces and tomcat as a server but before i use tomcat as a server, i used jboss
and my richfaces application worked,,
and then i tried to use tomcat and when i deploy there is no error in catalina.out
but when it called on the browser i got this messages


HTTP Status 404 -

type Status report

message

description The requested resource () is not available.
Apache Tomcat/7.0.11




there has to be changed anymore??
like pom.xml maybe or anything else


thanks in advance
 
Saloon Keeper
Posts: 21592
146
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Recent versions of JBoss have JSF-impl.jar built into the JBoss server. Tomcat does not, so you have to include it in the deployed WAR. You may have to include one or 2 other JARs as well, depending on what version of the core JSF you're using (I use the Sun RI these days).

If that doesn't help, show us what URL you submitted.
 
You guys haven't done this much, have ya? I suggest you study this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!