• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

MDB2.0 stoped listing to WebSphere Queue

 
Vivek Mathur
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am writing a asynchronous listener to WebSphere MQ server (Queue) from Jboss AS4.0(Actually a modified version called as SIAS server by GE). Trying to implement it using MDB (EJB spec2.0). This listener should only pick the data (xml format) from queue, parse it and dump it in Oracle DB.

I am able to receive message from Queue. however i am facing two issues.

1. When Jboss server starts, it starts giving exceptions: [JMS provider failed to connect: Retrying ....... javax.naming.exception ......... wsmq not bound]
and when the whole server gets up and running and the application is deployed, JMS Provider gets connected and MDB starts getting instantiated and receiving Messages from queue.

2. When there is no message on the queue for long time say more than an hour or two, and now after 2 hr. if you put some message on the queue, MDB stops receiving messages.

I have also not seen any traces of EJBRemove() being called, yet it stops receiving messages.


Can Any one please guide me.

Thanks for the help in advance.

Regards,
Vivek Mathur

 
Vivek Mathur
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


Can anyone help.


Regards,
Vivek Mathur
 
ravikanth reddy
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have similar issue with TibcoEMS and JBOSS still not resolved.

Can you check is your jboss.xml having below attributes

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic