• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
Sheriffs:
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
Bartenders:
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

The AXIS engine could not find a target service to invoke

 
Ranch Hand
Posts: 141
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi All,

I stucked with Axis 1.3 (please don't ask why 1.3...) and JDK 1.5 with webshpere.
i have very basic service 'Calculator' with two operations 'add' and 'subtract'
here is my server-config.wsdd file (placed under WEB-INF directory).



and here is my wsdl file.



when i try to invoke the service with simple client i am getting following error

AxisFault
faultCode: {http://xml.apache.org/axis/}Server.NoService
faultSubcode:
faultString: The AXIS engine could not find a target service to invoke! targetService is null
faultActor:
faultNode:
faultDetail:
{http://xml.apache.org/axis/}hostname:My_Host_Name

I am failed here to figure-out the problem.
for info,
i am getting expected results when i follow the urls
http://localhost:9080/TestService/services/Calculator
as
Hi there, this is an AXIS service!
Perhaps there will be a form for invoking the service here...

but when go to http://localhost:9080/TestService/servlet/AxisServlet and click the wsdl link (in actual it is http://localhost:9080/TestService/services/Calculator?wsdl) i am getting error messgae as
AXIS error
Could not generate WSDL!
There is no SOAP service at this location

Here is my web.xml file.


Could anyone please help me to know identify the problem.

 
vijay saraf
Ranch Hand
Posts: 141
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Ahh....

I got the problem...
My URLMapper was missing...
here is my new server-config.wsdd file



Well...........thanks all.
 
pie. tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic