Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Application is not working properly on Internet Explorer !??!?!?!

 
Peter Primrose
Ranch Hand
Posts: 755
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Wow, I realized that my application on Internet Explorer is not working properly and not aligned as it is on FireFox.

Example: the logout button that is always on the right is ignored on IE.



few of the action buttons when clicked on IE carries null value (as appose to FireFox where it carries the command action)

 
Brent Sterling
Ranch Hand
Posts: 948
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you just venting or asking for help? This does not sound like a Struts issue. If you are using basic html tags and your page is showing up quite different it may be that your html is not valid (something like a missing ending tag). I have found that browsers differ a bit in how they handle invalid html.

- Brent
 
Peter Primrose
Ranch Hand
Posts: 755
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thank you Brent.

Sorry if i wasn't clear....I'm asking for help!

you wrote:
I have found that browsers differ a bit in how they handle invalid html.


but in my case, the application looks utterly different in terms of the layout. The components are not aligned at all. furthermore, the submit-actions doesn't work properly.

what can I do?

thanks
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic