Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

MQ version 7.0.1 compatibility with Java 1.4 / 1.5 and 1.6  RSS feed

 
Pankaj Poshirkar
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear All,

Recently we upgraded our MQ to version 7.0.1 but the memory usage suddenly rose to 5 times the earlier memory usage.
We have Java code which connects to MQ. With the earlier version of MQ, the Java version we were using was 1.4.
But with the upgraded version of MQ (i.e. version 7.0.1 we are now using Java 1.5)...
I have heard that Java 1.5 uses 5 times more memory that Java 1.4. Is it true?

If that is the case, can we switch back to Java 1.4 keeping MQ version 7.0.1?
In other words, I want to know whether Java 1.4 is compatible with MQ version 7.0.1?

If anybody has any idea, can you please help me resolve my queries?

Regards,
Pankaj
 
Jaikiran Pai
Sheriff
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Pankaj Poshirkar wrote:
I have heard that Java 1.5 uses 5 times more memory that Java 1.4. Is it true?

Any reference to this claim?
 
Pankaj Poshirkar
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jaikiran Pai wrote:
Pankaj Poshirkar wrote:
I have heard that Java 1.5 uses 5 times more memory that Java 1.4. Is it true?

Any reference to this claim?
I have heard this from our client. And its not about Java in general... but JMS code used to connect to MQ version 7.0.1...
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!