Win a copy of Head First Android this week in the Android forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

Error while configuring weblogic8.1 with struts1.1

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I am trying my first struts application using weblogic8.1 server.I used Weblogic workshop and the application worked fine.But now I tried to use Eclipse3.2 as the IDE and weblogic8.1 as the server.
First it threw warnings regarding the struts*.tld files displaying
"java.sun.com"is not reachable .The same was the case with "www.bea.com".
I resolved these warning s but getting the tld files and placed it in the WEB-INF directory of my application.I added all the required jars struts.jar,commons-beanutils.jar...as external jars to the application.But when I start the server I get an exception
<Servlet: "action" failed to preload on startup in Web application: "StrutsProject".
javax.servlet.ServletException: org/apache/commons/logging/LogFactory
at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:990)...
and after that when I access the page using the url
http://localhost:7001/StrutsProject/login.do (I mapped "/login" in struts-config.xml) then I get an exception
<Error while using app descriptor files
java.io.FileNotFoundException: C:\bea\weblogic81\samples\domains\workshop\cgServer\stage\_appsdir_StrutsProject_war missing application.xml and/or weblogic-application.xml descriptors and

java.lang.NoClassDefFoundError
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27

on the webpage itself..
Can you please help me in resolving the problem
 
reply
    Bookmark Topic Watch Topic
  • New Topic