• Post Reply Bookmark Topic Watch Topic
  • New Topic

Apache Jackrabbit Connection Problem?  RSS feed

 
Rahi Akela
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Friends,
I am new to Apache Jackrabbit Content Repository,So I am unable to understand,What's the exact problem,I am facing,Whenever I am starting Jboss server.
*****************************************************************************************************
2011-09-19 15:03:24,760 WARN [org.apache.jackrabbit.core.config.ConfigurationErrorHandler] [main] [] Warning parsing the configuration at line 1 using system id file:/C:/app-server/jboss/server/moksha/data/moksha/jcr/repository.xml: org.xml.sax.SAXParseException: Document root element "Repository", must match DOCTYPE root "null".
2011-09-19 15:03:24,760 WARN [org.apache.jackrabbit.core.config.ConfigurationErrorHandler] [main] [] Warning parsing the configuration at line 1 using system id file:/C:/app-server/jboss/server/moksha/data/moksha/jcr/repository.xml: org.xml.sax.SAXParseException: Document is invalid: no grammar found.
2011-09-19 15:03:25,041 INFO [org.apache.jackrabbit.core.RepositoryImpl] [main] [] Starting repository...
2011-09-19 15:03:25,056 INFO [org.apache.jackrabbit.core.fs.local.LocalFileSystem] [main] [] LocalFileSystem initialized at path F:\jcr-repo\repository
2011-09-19 15:03:25,353 INFO [org.apache.jackrabbit.core.nodetype.NodeTypeRegistry] [main] [] no custom node type definitions found
2011-09-19 15:03:25,369 INFO [org.apache.jackrabbit.core.fs.local.LocalFileSystem] [main] [] LocalFileSystem initialized at path F:\jcr-repo\version
2011-09-19 15:03:26,541 INFO [org.apache.jackrabbit.core.persistence.bundle.util.ConnectionRecoveryManager] [main] [] Database: PostgreSQL / 8.3.8
2011-09-19 15:03:26,541 INFO [org.apache.jackrabbit.core.persistence.bundle.util.ConnectionRecoveryManager] [main] [] Driver: PostgreSQL Native Driver / PostgreSQL 8.3 JDBC4 with SSL (build 604)
2011-09-19 15:03:26,760 ERROR [org.apache.jackrabbit.core.persistence.bundle.util.ConnectionRecoveryManager] [main] [] could not execute statement, reason: ERROR: relation "jackrabbit_version_bundle" does not exist, state/code: 42P01/0
2011-09-19 15:03:27,525 INFO [org.apache.jackrabbit.core.persistence.bundle.util.ConnectionRecoveryManager] [main] [] Database: PostgreSQL / 8.3.8
2011-09-19 15:03:27,541 INFO [org.apache.jackrabbit.core.persistence.bundle.util.ConnectionRecoveryManager] [main] [] Driver: PostgreSQL Native Driver / PostgreSQL 8.3 JDBC4 with SSL (build 604)
2011-09-19 15:03:27,556 ERROR [org.apache.jackrabbit.core.persistence.bundle.util.ConnectionRecoveryManager] [main] [] could not execute statement, reason: ERROR: relation "jackrabbit_version_bundle" does not exist, state/code: 42P01/0
2011-09-19 15:03:27,556 ERROR [org.apache.jackrabbit.core.persistence.bundle.PostgreSQLPersistenceManager] [main] [] failed to read bundle: deadbeef-face-babe-cafe-babecafebabe: org.postgresql.util.PSQLException: ERROR: relation "jackrabbit_version_bundle" does not exist
2011-09-19 15:03:27,556 ERROR [org.apache.jackrabbit.core.RepositoryImpl] [main] [] failed to start Repository: failed to read bundle: deadbeef-face-babe-cafe-babecafebabe: org.postgresql.util.PSQLException: ERROR: relation "jackrabbit_version_bundle" does not exist
javax.jcr.RepositoryException: failed to read bundle: deadbeef-face-babe-cafe-babecafebabe: org.postgresql.util.PSQLException: ERROR: relation "jackrabbit_version_bundle" does not exist: failed to read bundle: deadbeef-face-babe-cafe-babecafebabe: org.postgresql.util.PSQLException: ERROR: relation "jackrabbit_version_bundle" does not exist
at org.apache.jackrabbit.core.version.VersionManagerImpl.<init>(VersionManagerImpl.java:173)
.....................................
.....................................
at java.lang.Thread.run(Thread.java:662)
Caused by: org.apache.jackrabbit.core.state.ItemStateException: failed to read bundle: deadbeef-face-babe-cafe-babecafebabe: org.postgresql.util.PSQLException: ERROR: relation "jackrabbit_version_bundle" does not exist
...........................
...........................
at org.apache.jackrabbit.core.version.VersionManagerImpl.<init>(VersionManagerImpl.java:142)
... 118 more
Caused by: org.postgresql.util.PSQLException: ERROR: relation "jackrabbit_version_bundle" does not exist
at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:1608)
.........................
.........................
at org.apache.jackrabbit.core.persistence.bundle.PostgreSQLPersistenceManager.loadBundle(PostgreSQLPersistenceManager.java:94)
... 121 more
org.apache.jackrabbit.core.state.ItemStateException: failed to read bundle: deadbeef-face-babe-cafe-babecafebabe: org.postgresql.util.PSQLException: ERROR: relation "jackrabbit_version_bundle" does not exist
at org.apache.jackrabbit.core.persistence.bundle.PostgreSQLPersistenceManager.loadBundle(PostgreSQLPersistenceManager.java:117)
.......................
.......................
at java.lang.Thread.run(Thread.java:662)
Caused by: org.postgresql.util.PSQLException: ERROR: relation "jackrabbit_version_bundle" does not exist
at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:1608)
..............................
..................................
at org.apache.jackrabbit.core.persistence.bundle.PostgreSQLPersistenceManager.loadBundle(PostgreSQLPersistenceManager.java:94)
... 121 more
2011-09-19 15:03:27,572 INFO [org.apache.jackrabbit.core.RepositoryImpl] [main] [] Shutting down repository...
2011-09-19 15:03:27,619 INFO [org.apache.jackrabbit.core.RepositoryImpl] [main] [] Repository has been shutdown

**************************************************************************************
Please help me!
Thanks in advance.
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!