Win a copy of The Way of the Web Tester: A Beginner's Guide to Automating Tests this week in the Testing forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Node Manager fails to restart one of the two instances on OS reboot

vinay vishwanathan
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Guys,

I have seen a lot of posts on Node Manager but could not find the solution to my problem. So I am posting this as a new Thread. Please let me know if I missed out on any of the previous posts.

I have a Admin Server and 2 Managed Servers in a cluster. Both the MS are running on the same machine and Admin server on a different machine. I have configured a NM for the machine and both Managed servers are under NM control. I am able to use the NM to stop/start the Managed servers via Admin Console and WLST.

The problem lies when Solaris is rebooted. During Solaris reboot only one of the two servers comes back to running and the other does not. I have checked all configurations and the behaviour is really surprising.

I have placed the start up script for NM restart in rc3.d which refers to init.d.

Weblogic version -
Node Manger version -
Solaris version - SunOS 5.10 sun4v sparc SUNW,SPARC-Enterprise-T5220

I am happy to share the scripts and further details. Any help is really appreciated as this is the last bit of work left in my Project and Weblogic auto restart is critical for Ops sign off.

  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic