• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Error in jsp when making jstl change

 
dhaval tamboli
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

It seems very stupid and annoying error I am getting.
I have one jsp page which already uses jstl.

now if i add any new jstl variable or new condition. whole layout of jsp page gets mess.
I'm using jstl1.0.

I'm not sure what might be the problem and what may cause it. e.g. adding messes my jsp page.
did anybody face this kind of problem?
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65216
95
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just the addition of that tag will have no effect on the HTML and therefore the layout of the page. However, is there code later in the page that does something differently based upon the setting of that scoped variable?

Also, have you compared the rendered HTML in each case to see what has changed? That could give you a clue to the cause of the issue.
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65216
95
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
JSTL 1.0? Why? If you are not using an ancient version of a servlet container (such as Tomcat 4), you should be using the compatible version of JSTL.
 
dhaval tamboli
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How would I know, which is compatible version of jstl? i'm using JRun4 as server
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65216
95
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What version of the servlet and JSP specifications is supported? If you don't know, then you need to find out before doing anything else.
 
dhaval tamboli
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yeah, i need to keep jstl1.0
servlet:2.3 and jsp:1.2
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65216
95
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Why are you using such an antiquated container?

In any case, what're the answers to my other questions?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic