• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Unable to open the service 'tomcat6'

 
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I have tried to run the tomcat6w.exe first on two different machines, one running Windows 7 and the other Windows XP SP2 and I get this error every time:


The specified service does not exist as an installed service.
Unable to open the service 'tomcat6'



I have googled this issue and could not find any clear solutions.
There are however two main solution suggestions, neither of which has worked for me:

1 - https://issues.apache.org/bugzilla/show_bug.cgi?id=41538 : This solution suggests copying the msvcr71.dll from %JAVA_HOME%\bin to %SYSTEM_ROOT%\system32 or any other location on the path. However, I am not missing this .dll in my system32 folder.
2 - http://www.coderanch.com/t/87314/Tomcat/installation-tomcat : This solution suggests that it is because the windows user is not authorised to install system services. NOw, I have administrator privileges in both computers and furthermore one of them is my own laptop so I think I should not have privilege issues. This link alternatively suggests running the tomcat by the catalina.bat. However, when I click on the catalina.bat on both machines, a one line command prompt window flickers for half a second and disappears.

Initially, I was convinced that this may be an authorisation issue but after trying it on my own laptop and getting the same result, I think there is something else that is wrong.
Strangely, there is no clear solution for this on the web. Does anyone have any ideas?

P.S: I get the same error for tomcat7w.exe as well)

Thanks,
Berkan
 
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try the Tomcat 6 documentation. Here's a topic that discusses this very issue: http://tomcat.apache.org/tomcat-6.0-doc/windows-service-howto.html

Alternatively, you can just startup Tomcat via the command line or through a script:

1) Open the command line (run as administrator if necessary)
2) cd to your Tomcat installation bin directory
3) type startup.bat

Hope this helps,
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi Charles,
I also got the same error message as Berkan got. Thank you for comment, now i can able to run tomcat
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!