Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Java Program on Amazon EC2

 
Palak Agarwal
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I am trying to run java program on amazon's EC2 server. To do so I am using eclipse IDE, where it is required to install the AWS(amazon webservices plugin). While installation it is giving the following error:

"An error occurred while collecting items to be installed
session context wasprofile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.amazonaws.eclipse.core,2.0.0.v201110211341
No repository found containing: org.eclipse.update.feature,com.amazonaws.eclipse.core.feature,2.0.0.v201110211341
No repository found containing: osgi.bundle,com.amazonaws.eclipse.datatools.enablement.simpledb,1.0.0.v201110211341
No repository found containing: osgi.bundle,com.amazonaws.eclipse.datatools.enablement.simpledb.dbdefinition,1.0.0.v201110211341
No repository found containing: osgi.bundle,com.amazonaws.eclipse.datatools.enablement.simpledb.driver,1.0.0.v201110211341
No repository found containing: osgi.bundle,com.amazonaws.eclipse.datatools.enablement.simpledb.editor.ui,1.0.0.v201110211341
No repository found containing: org.eclipse.update.feature,com.amazonaws.eclipse.datatools.enablement.simpledb.feature,1.0.0.v201110211341
No repository found containing: osgi.bundle,com.amazonaws.eclipse.datatools.enablement.simpledb.ui,1.0.0.v201110211341
No repository found containing: osgi.bundle,com.amazonaws.eclipse.datatools.sqltools.db.simpledb,1.0.0.v201110211341
No repository found containing: osgi.bundle,com.amazonaws.eclipse.datatools.sqltools.tablewizard.simpledb,1.0.0.v201110211341
No repository found containing: osgi.bundle,com.amazonaws.eclipse.ec2,1.1.0.v201110211341
No repository found containing: org.eclipse.update.feature,com.amazonaws.eclipse.ec2,1.1.0.v201110211341
No repository found containing: osgi.bundle,com.amazonaws.eclipse.elasticbeanstalk,1.0.0.v201110211537
No repository found containing: org.eclipse.update.feature,com.amazonaws.eclipse.elasticbeanstalk.feature,1.0.0.v201110211537
No repository found containing: osgi.bundle,com.amazonaws.eclipse.rds,1.0.0.v201110211341
No repository found containing: org.eclipse.update.feature,com.amazonaws.eclipse.rds.feature,1.0.0.v201110211341
No repository found containing: osgi.bundle,com.amazonaws.eclipse.sdk,1.2.10.v201110171716
No repository found containing: org.eclipse.update.feature,com.amazonaws.eclipse.sdk.feature,1.2.10.v201110171716
No repository found containing: osgi.bundle,com.amazonaws.eclipse.sdk.ui,1.0.0.v201110171716"
 
Karthik Shiraly
Bartender
Posts: 1208
25
Android C++ Java Linux PHP Python
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What version and "flavour" (ie, "Eclipse classic" / "Eclipse for JavaEE developers" / etc) are you using?
AWS toolkit requires atleast Eclipse 3.6 (helios) and the JavaEE flavour.
 
Palak Agarwal
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I am using eclipse helios and still it was giving error while installation.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic