Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

I hate spending 3 weeks on the tools, not coding

 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK, so I will say that I am using Milestones and Release Candidates, but still, I should get my IDEs to work. And I know in this case it isn't really the IDE that is to blame, but me myself and I.

So In my Grails 2.0 app using IntelliJ, I can't get it to generate Controllers. Well that isn't IntelliJ stuff. But it is Grails stuff. Here is my error for that



At first I thought it was when I added Spock

test ":spock:0.6-SNAPSHOT"

But that isn't it.

Let me go to the other IDE, that is my most favorite IDE ever created in mankind. The one IDE that you are guaranteed to work the best after you spend 90% of your time fixing it.

So in Eclipse(STS), I created a Spring ROO project (I know not Groovy or Grails here, just wait), it was great built all the scaffolding and such just like Grails does. However, I know that I would love to have some Groovy classes/code in my app to simplify a lot of stuff I need to customize. Here is where STS fails, I can't get it to compile a .groovy file, in the IDE I get two red x's for missing a semicolon. First on the package line and the second on the last line. It won't even show errors for the imports that are missing so far.

Any ideas of how to get Groovy to work in Eclipse. I even went through STS's dashboard and "install" Groovy, but that doesn't work. I am also using the latest Groovy 1.8.2

Thanks

Mark
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Don't know what I did right, but I got the IntelliJ Grails app to compile and allow me to generate Controllers and Views for one of my domain objects.

I think this might have done the trick, in my BuildConfig.groovy I added two exclused for those jmx stuff that log4j wanted.

inherits("global") {
// uncomment to disable ehcache
excludes 'ehcache'
excludes 'jmxtools'
excludes 'jmxri'
}
Lets see how far I can get now.

Mark
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic