Win a copy of The Way of the Web Tester: A Beginner's Guide to Automating Tests this week in the Testing forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WebSphere 8 and WebLogic 10.3.5 EJB transaction propagation

Jarny Zearey
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I am at the moment developing a solution where I would have to implement EJB remote method invocation in transactional enviroment. This should be done for invocation from WebSphere application server 8 to WebLogic application server 10.3.5 and other way around.

At the moment I am able to invoke an EJB method from WAS to WLS. For this I have imported wlfullclient.jar and interface lib to WAS.

Code on WAS:

On WLS I have a method on EJB anotated with @TransactionalAttribute(MANDATORY) with remote interface. I call this method from WAS EJB method annotated @TransactionalAttribute(REQUIRED)

I get the following exception on WAS:

[14.11.11 11:45:50:843 CET] 00000029 SystemOut O weblogic.logging.MessageLogger log <14.11.2011 11:45:50 CET> <Error> <IIOP> <BEA-002015> <Using javax.rmi.CORBA.UtilClass; The IIOP subsystem requires a WebLogic Server-compatible UtilClass.>
I have tried to use WLS UtilClass but with no success. I also tried to use SUN or WAS initial context factory, but I can not retrieve an object from lookup. Looks like lookup string is not right.

Besides this I also tried in different direction. Meaning to call EJB from WLS to WAS. Here I was able to invoke EJB method when I imported required libraries to WLS: and and endorsed_apis_8.0.0.jar. Code looks like this:

It was also necesary to create remote Stubs manually using createEJBStubs. After this I was able to call a method on WAS without anotation TransactionalAttribute(Mandatory) which means that transaction did not propagate. The error was:

[22.11.11 17:08:49:875 CET] 0000000c BusinessExcep E CNTR0019E: EJB threw an unexpected (non-declared) exception during invocation of method "ejbMethod". Exception data: global tx required

I also tried to use SUN on WLS initial context factory but i was unable to do a lookup. Does anyone have any idea how this should be done properly?

I would really appreciate if anyone has some experience doing something simmilar on WAS7 or WAS8. I am kind of stuck here.

Thank you!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic