Win a copy of Java Mock Exams (software) this week in the Programmer Certification (OCPJP) forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

does not start with a "/" character

 
Erap Estrada
Ranch Hand
Posts: 92
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This is solution topic. The reason i am posting this is because, ive read 4 struts books but an extra steps of installation below was never mentioned in those books.

If you're getting problem similar to:

javax.servlet.ServletException: Path loginLayout does not start with a "/" character


Here's what you got to do:

Step 1. add chain-config.xml to WEB-INF folder inside your project
you can find this file in
/struts-1.3.5-all/struts-1.3.5/src/tiles/src
/main/resources/org/apache/struts/tiles

Step 2.
add the following init-param tag to Action Servlet configuration in web.xml



Step 3.
add commons-chain-1.1.jar to your project library.


This solution i found is from this blog
 
Sreejith Sasidharan
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi...

I was facing issue in Eclipse + Tomcat..(never came in oracle Jdeveloper/oc4j) not sure which is the culprit but your solution fixed my problem. I was finding hard to solve and spent nearly 2 hrs and then found this solution

Cheers

Sree

 
Happiness is not a goal ... it's a by-product of a life well lived - Eleanor Roosevelt. Tiny ad:
the new thread boost feature: great for the advertiser and smooth for the coderanch user
https://coderanch.com/t/674455/Thread-Boost-feature
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!