Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

JBoss Seam and JSF

 
Ranch Hand
Posts: 94
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am newbe with JBoss Seam. I am using 2.2.0 GA version. My problem is that I cannot display a JSF page.
When I invoke it I see a blank page. Here is my code,

Then bean (HomeBean),



The JSF page (index.xhtml),



I am thinking I have to do some declarations in the faces-config.xml file but I do not know what is it.

Please help.

Kind regards,
Jose
 
Ranch Hand
Posts: 754
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What is the link that you is using to access?

Without the line bellow, you can see the page?
<s:link action="#{homeBean.send}" value="Send email"/>
 
Jose Alvarez de Lara
Ranch Hand
Posts: 94
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Herbert,

If I add a little hardcode like 'Helo world' I can see it.

It's the <s:link> tag what I cannot see

Thnaks,
Jose
 
Hebert Coelho
Ranch Hand
Posts: 754
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Change the <head> for <h:head> and do the same with the body tag.
 
Jose Alvarez de Lara
Ranch Hand
Posts: 94
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I get the following message,

Warning: This page calls for XML namespace http://jboss.com/products/seam/taglib declared with prefix s but no taglibrary exists for that namespace.

Whitch is the taglibrary?

Thanks,
Jose
 
Hebert Coelho
Ranch Hand
Posts: 754
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The seam lib. Is it in your lib folder and project class path?
 
Jose Alvarez de Lara
Ranch Hand
Posts: 94
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Take a look at this web, it seems that resolve my issue

Seam Data Validation

Thank you for your interesting.

Kind regards,
Jose
 
A sonic boom would certainly ruin a giant souffle. But this tiny ad would protect it:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic