Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Unable to create Spring AOP archetype using Maven in Eclipse

 
pramod talekar
Ranch Hand
Posts: 366
Eclipse IDE Java Opera
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I have m2eclipse plugin installed in Eclipse 3.7.

I want to create a spring project with dependencies like aop, context etc. of version 3.0.2 using Maven 3.

So which default archetype should I use ? e.g. the one with artifact ID org.springframework.osgi

I tried to create an archetype with GroupID org.springframework, Artifact Id : spring-aop, Version 3.0.2.RELEASE, but got error saying that the defined artifact is not an archetype for both spring-aop & spring-context.

Please advise.

 
Atul Kotwale
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
create a maven project for the jar and in pom.xml add decencies for spring3.0. If you want to create web application then WAR archetype is also present.
 
pramod talekar
Ranch Hand
Posts: 366
Eclipse IDE Java Opera
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Atul,

I'm not sure about WAR archetype.
Is it fine if I use org.springframework.osgi ?
Also what is the reason behind not able to create a new archetype ?
 
Atul Kotwale
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have created several project using war archetype that is why i suggested you. I do not know exact reason why you do not create it ?
 
pramod talekar
Ranch Hand
Posts: 366
Eclipse IDE Java Opera
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You mean to say the one with the Artifact Id ' spring-mvc-webapp' ?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic