Rob Spoor wrote: . . . I'd still prefer a separate method though.
Agree. Fall-through will confuse the next person who reads that code.
Seconded. I think they could have saved us all a lot of bother (and break statements) by just making each section an independent block. After all, you can't use Duff's device, which is why a lot of us old C-ers liked the original syntax.
"Leadership is nature's way of removing morons from the productive flow" - Dogbert
Articles by Winston can be found here
i guess i make it unanimous. method calls are the best way to go. i have written quite a few if-else and switch statements and put all the code in them. most of the time when i read them later i see i should have created a method or two and called them instead