Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

module has not been deployed

 
Ranch Hand
Posts: 692
Eclipse IDE Java Linux
  • Mark post as helpful
  • send pies
  • Report post to moderator
after so many days i m unable to solve this problem
when ever i run my web app (new to j2ee) using tomcat 7 and netbeans7 i receive a error or exception saying module has not been deployed
whats wrong please any one explain me how to fix it ?
may be this could help you to figure out the problem
 
Ranch Hand
Posts: 73
  • Likes 1
  • Mark post as helpful
  • send pies
  • Report post to moderator
is the .war file has been created in the DIST/ folder of your net beans project directory? Copy that war file to web apps folder of tomcat and try to verify if its manually deploying or not
 
naved momin
Ranch Hand
Posts: 692
Eclipse IDE Java Linux
  • Mark post as helpful
  • send pies
  • Report post to moderator

saahil gupta wrote:is the .war file has been created in the DIST/ folder of your net beans project directory? Copy that war file to web apps folder of tomcat and try to verify if its manually deploying or not


thanks , you replied , no one is ready to solve this problem i guess , anywhere i m not getting correct answer
the problem is when war file is deployed manually and then we can access the webapp properly but the same project is not running from netbeans
or no webapp is running from netbeans i guess its surely a deployment issue , but i dont know how netbeans deploy the file to the tomcat/webapp directory thats why i cannot come up
a solution
please if any one has the same problem explain how you have solved it ?
 
Sheriff
Posts: 21759
102
Eclipse IDE Spring VI Editor Chrome Java Ubuntu Windows
  • Likes 1
  • Mark post as helpful
  • send pies
  • Report post to moderator
This is the third time you bring up this problem; see http://www.coderanch.com/t/563938/java/java/why-getting-exception-java-lang and http://www.coderanch.com/t/564173/vc/does-exception-means-module-has. Please UseOneThreadPerQuestion. I'm closing this thread.
    Bookmark Topic Watch Topic
  • New Topic
Boost this thread!