• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Java mail problem in IE

 
mallikarjun dontamsetti
Ranch Hand
Posts: 246
Firefox Browser Oracle
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi i have implemented some code to send mail in java it is working in chrome and firrfox. But in IE it is showing empty page my code is



It is called in my servlet like this


Please help me with this
 
Maneesh Godbole
Saloon Keeper
Posts: 11096
13
Android Eclipse IDE Google Web Toolkit Java Mac Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What do you get on the printStackTrace()?
Also, I hope you realize, the JOptionPane.showXXXDialog will be executed on the server side and your client will never see it.

Moving to a more appropriate forum
 
mallikarjun dontamsetti
Ranch Hand
Posts: 246
Firefox Browser Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I IE it is showing a blank page with same URL as chrome and firefox. But in chrome and firefox showing the page correctly. Is there any problem with IE browser session closing
FYI : My page taking nearly 30 sec to display next page in chrome and firefox
 
Paul Clapham
Sheriff
Posts: 21322
32
Eclipse IDE Firefox Browser MySQL Database
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maneesh Godbole wrote:What do you get on the printStackTrace()?
 
mallikarjun dontamsetti
Ranch Hand
Posts: 246
Firefox Browser Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Nothing in my printStackTrace(). the problem is with IE 9 browser only(i have to test lower versions of IE). am i need to change some settings in my IE
 
Paul Clapham
Sheriff
Posts: 21322
32
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We are asking because we suspect that your server code (what you posted) is throwing an exception, and that different browsers are interpreting a combination of partial HTML code plus a 500-level error code differently. You never have to configure the browser to receive normal HTML responses, so it looks like you aren't sending a normal HTML response.

So there are several things you should be looking into. Does your server code throw an exception, or is the e-mail sent successfully? Are you sending any HTML at all as your response? What is the response code sent by your code: 200 for normal, or something else? You'll notice that all of this is at the server side; the browser should have nothing to do with it.
 
mallikarjun dontamsetti
Ranch Hand
Posts: 246
Firefox Browser Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There are no errors the mail is sending well wheen i use chorm or firefox but in IE it is not showing any error and mail also not going.
 
Paul Clapham
Sheriff
Posts: 21322
32
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Let's clarify. You casually mentioned a "servlet" and we are therefore assuming that IE, Firefox, and so on are browsers which are sending the request to a server, which is where the servlet runs. Is that correct? Because you are continually going on about the browsers, as if this code is perhaps in an applet or something like that.
 
mallikarjun dontamsetti
Ranch Hand
Posts: 246
Firefox Browser Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When i tried in IE9 my welogic server log file show me this error
<Warning> <Socket> <BEA-000449> <Closing socket as no data read from it during the configured idle timeout of 5 secs>
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic