• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

facing not a know entity type problem in spring...plzz help me...

 
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am facing a problem in spring jpa. I am not able to find what kind of error is this as I think my code is fine...



Service class is:



Dao class is:



Spring xml is:



persistence xml:



ANd entity class is:



I am getting this error:

Object: com.infosys.ingreen.middleware.entity.ElectricDeviceEntity@141fab6 is not a known entity type.



As I have searched out, many people faced this prob because of some compatibility issue, especially with eclipseLink. I am using spring 3 with toplink. What can be the cause of error? When I deleted the entity from table without spring, it worked...!!!
 
Ranch Hand
Posts: 553
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It is most likely some kind of class loader issue. You probably have the class loaded with two different class loaders.

If you just read, does it work? Check the difference in the class loaders from reading versus your app.

If you disable weaving does it work?
reply
    Bookmark Topic Watch Topic
  • New Topic