• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Knute Snortum
  • Rob Spoor
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Piet Souris
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

war file generated by eclipse works only inside of eclipse

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Guys and Girls !

I have this trouble. I'm working with Eclipse 3.7 and the plugins of Google Web Toolkit, my application is function only inside of the Eclipse but when I try out of Eclipse like JBoss 5.10 It doesn't work .. I don't understand why? I have read many information about this but I can not find the solution.

The JBoss 5.10 work with JDK 6 , I have read this ..

Can someone help me ?

Thanks
 
clojure forum advocate
Posts: 3479
Mac Objective C Clojure
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi and welcome to the Ranch
What do you mean by it isn't working?

my application is function only inside of the Eclipse but when I try out of Eclipse like JBoss 5.10 It doesn't work


Tell us more to be able to help you.
 
joel chacon
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have created one application with Eclipse 3.7 and the plugin for GWT. It has 4 services with RCP and one client. The services are very simple. When I deploy my application inside of Eclipse, It run fine and is working in my browser as good as I hope, but when I create a file war with a option that Eclipse-plugin have and deploy It over Apache Tomcat 7 or JBoss 5.10 It's not working and I don't understand why ...

I've read some articles about this trouble and one of them said that the deployed file that Eclipse create doesn't follow the standard java for web applications but this is not true. I have compared this with the standard and It follow the standard.

Do you have some idea about this?

 
Hussein Baghdadi
clojure forum advocate
Posts: 3479
Mac Objective C Clojure
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Joel,
Again, what do you mean by:

It's not working and I don't understand why ...


Tell us how it isn't working, exception is thrown for example?
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!