Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Issue with RMi

 
deepak carter
Ranch Hand
Posts: 165
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I created following classes








class path are set just fine...
As in the one the blog it it mentioned that in java 1.5 or later no need for rmic for stub and skeleton...

when i am starting the rmiregistry in command prompt using following syntax

start rmiregistry its starting up fine


the problem is when i am starting the server file its showing a huge error...I tried searching google but no use..

Can anyone of you can help in this


here is the rror which i am getting when i am running the server
 
Yasin Kothia
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I cant see the error message
 
deepak carter
Ranch Hand
Posts: 165
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
it didnt got posted bt if we try to run server its showing huge error
 
Yasin Kothia
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
please paste the error in a block code,

dont worry about it being so long.
 
kien kun
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think you don't complie file(.class) Which will make two class stub and steke
 
Yasin Kothia
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have tested the code, and it works just fine.

response: Hello, world!


What you need to is recompile the .java classes via command prompt (javac) not via a IDE and see if that works for you.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic