This week's book giveaway is in the JavaScript forum.
We're giving away four copies of Svelte and Sapper in Action and have Mark Volkmann on-line!
See this thread for details.
Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Glassfish deployment issues

 
Ranch Hand
Posts: 41
IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello fellow ranchers,

So below is the error I'm getting when i try to deploy my store portion of my app. This sever error for Invalid InputStream returned for applies for every jar in the project. Is it because the jars are already present or is it because they are not being exported to the project?
I''ve never encountered this error before. I've tried to google this problem but no success. Any help or nudge in the right direction would be appreciated.
 
Joseph Swager
Ranch Hand
Posts: 41
IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Here is a list of the Jars for the apps in there WEB_INF/lib directory. Hope that helps

 
Joseph Swager
Ranch Hand
Posts: 41
IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When i try at the command line and do a forced deploy here is the errors I get

 
Joseph Swager
Ranch Hand
Posts: 41
IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi everyone. So I redid the domain on glassfish and it seems not to help any. Although the errors I think are being a little more discriptive, but I'm still lots as to what the JAR issue I think I'm having.

Any Ideas or hints would be most appreciated. In the meantime Ill continue to find a solution and will share with the community if I find one.

Thanks all.

 
Joseph Swager
Ranch Hand
Posts: 41
IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello fellow ranchers,

SOLVED IT!!!

So it appears that jboss wouldn't complain about having to jars of jboss-system

I removed jboss-system-1.3.0.jar and it it has deployed everytime I've tried on glassfish. I hope that helps someone with this crazy issue I've had for over a week.

Can someone explain why the jboss 4.2 server we deploy on currently doesn't blow up like glassfish does?

Happy Coding

Joe
    Bookmark Topic Watch Topic
  • New Topic