Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

GWT maven app not starting

 
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I created a GWT app project using the gwt-maven-plugin and added the same to eclipse. Tried running it from eclipse (as a web application) however got the following errors (screenshot). Any ideas on why this would be happening?

Would like to mention that the app builds fine and when i manually deploy that war file in tomcat, the app works as expected. However running from eclipse causes issues.

Cross posted here
 
Nev Mehta
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Add target/generated-sources/gwt to the Eclipse build path. This is not done automatically, unfortunately. This solved my problem. Source
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic