Win a copy of Cross-Platform Desktop Applications: Using Node, Electron, and NW.js this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem executing a command after startup(OSX 10.7)  RSS feed

Vadim Korotchenko
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I am having some issues with tomcat on startup. In my program tomcat executes an Imagemagick command but it fails to do so right after startup,but if I either start tomcat manually or restart tomcat using(sudo and everything works fine. I suspect it has something to do with the plist, but I hit a wall. This is what I have so far:

- my plist calls a script which is a launchd wrapper:

- the script starts tomcat

The only other thing I have found is that when I run "sudo ./" the console displays:

sudo: <<USERNAME>> : TTY=ttys002 ; PWD=/Library/Tomcat/apache-tomcat-6.0.29/bin ; USER=root ; COMMAND=/Library/Tomcat/Home/bin/

whereas if I run "sudo launchctl load -w /Library/LaunchDaemons/myplist.plist "

sudo: <<USERNAME>> : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/Library/Tomcat/Home/bin/

Any thoughts or ideas will be greatly appreceiated
Thank you

  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!