Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Stable Standalone JMS Messaging Provider from JBoss

 
Vishwa Kumba
Ranch Hand
Posts: 1066
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am not clear about the versions available in JBoss for Messaging.

If I were to use a stable standalone messaging product(JMS Provider) from JBoss, which version would I use?

I had assumed that the JBoss stable version for production use(with Redhat support) is 5.1.2. (JEE 5) and hence
the stable JMS Provider is also JBoss Messaging 1.4.(default JMS Provider for JBoss EAP 5.1.2)

But when I tried downloading from RedHat site, I obtained jboss-eap-hornetq-5.1.2-installer for 5.1.2.
If I am not mistaken, HornetQ(JBoss Messaging 2.0) is supposed to be part of JBoss EAP 6.0(JEE 6). Right?

If it is, then how do I download the standalone version of the JMS Provider(JBoss Messaing 1.4) from JBoss?

 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Vishwa Kumba wrote:

If I were to use a stable standalone messaging product(JMS Provider) from JBoss, which version would I use?

I would use HornetQ.

Vishwa Kumba wrote:
If I am not mistaken, HornetQ(JBoss Messaging 2.0) is supposed to be part of JBoss EAP 6.0(JEE 6). Right?

It's also available in JBoss EAP 5.1.2. See the platform components table here. It's not called JBoss Messaging 2.0 anymore. That name was used very early when HornetQ was just being developed. Now it's called HornetQ.

Vishwa Kumba wrote:
If it is, then how do I download the standalone version of the JMS Provider(JBoss Messaing 1.4) from JBoss?


If you still want to use JBoss Messaging 1.x then the downloads are here http://www.jboss.org/jbossmessaging/downloads. However, note that there's no more development going on in JBoss Messaging project and HornetQ is the current active project. So I would use HornetQ instead of JBoss Messaging.

 
Vishwa Kumba
Ranch Hand
Posts: 1066
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks Jaikiran,
I didn't check the response here as I had obtained the response at the JBoss forums.

We have decided to go for JBoss Messaging 1.4 and JBoss 5.x. Later on, port it to JBoss 6.x and HornetQ.

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic