Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem redirecting through HTTPS

 
vishwamitra hegde
Greenhorn
Posts: 7
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi. I have have two web-applications running on two different servers which are communicating through HTTPS.
I have implemented SSL keystore, certificate and all the necessary arrangements to run secure port.
I am able to view pages securely when i run individually. But when i try to redirect form one application to another application's page through HTTPS, IE7 showing error message "Internet Explorer cannot display the webpage".
Note : It is working finely in Mozilla Firefox.Please help me out resolving this issue.

Thanks!
 
Tim McGuire
Ranch Hand
Posts: 820
IntelliJ IDE Tomcat Server VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think you have told Firefox to ignore the certificate warning for the second web site. You have a self-signed certificate, right?
Clear the security exception out of Firefox and try it.

With self-signed certificates this redirect will always fail. This is by design. Browsers allow you to bypass this for development purposes and they have different ways of going about this bypass.
 
vishwamitra hegde
Greenhorn
Posts: 7
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tim McGuire wrote:I think you have told Firefox to ignore the certificate warning for the second web site. You have a self-signed certificate, right?
Clear the security exception out of Firefox and try it.

With self-signed certificates this redirect will always fail. This is by design. Browsers allow you to bypass this for development purposes and they have different ways of going about this bypass.


Yes I have self signed ceritificate. When I clear exception in Firefox and try, it asked for security confirmation. I have added security exception and it works finee.
Could you please explain me how to add security exception in IE7? Or any other solution to make it work.

Thanks!
 
Tim McGuire
Ranch Hand
Posts: 820
IntelliJ IDE Tomcat Server VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Firefox has the ability to turn off this warning on a site by site basis.

Internet Explorer lets you turn warnings on or off (Tools --> Internet Options --> Advanced -->Security -- uncheck "warn about certificate address mismatch") for all sites. This is of course dangerous if you use IE for anything other than testing your own apps. I don't know of a way to do this on a site-by-site basis for IE. Of course turning this off for your browser won't fix it for other visitors to your web site.

EDIT: I only have IE9. IE7 should allow you to make a security exception permanent similar to firefox.

This page discusses all browsers:
http://cedarweb.hao.ucar.edu/wiki/index.php/Help:Security_Exception
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic