This week's book giveaway is in the Reactive Progamming forum.
We're giving away four copies of Reactive Streams in Java: Concurrency with RxJava, Reactor, and Akka Streams and have Adam Davis on-line!
See this thread for details.
Win a copy of Reactive Streams in Java: Concurrency with RxJava, Reactor, and Akka Streams this week in the Reactive Progamming forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Ganesh Patekar

ClassNotFoundException - but the class is there

 
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I have the following problem:

I have this faces-config.xml file:



and I get a ClassNotFoundException on the UserPhaseListener class when I start my server.

the class is infact there.. here's the package and class name:



I'm running on JBoss AS 7.1.1 (Brontes), but this used to work today hehehe.. don't know what has happened here, perhaps I'm missing some configuration.

Any ideas?

Thanks!
 
Rodrigo Sasaki
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think this is more of a JBoss Topic than a JSF one.

I opened the "%JBOSS_HOME%\standalone\deployments" folder and my deployment was there, the folders (package structure) was all there...

but not the .class files.. anybody know why?

Thanks!
 
Rodrigo Sasaki
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't know exactly what it was, but it was a problem with the Primefaces 3 jar.

we switched back to primefaces-2.2.1 and it worked.

Thanks
 
You totally ruined the moon. You're gonna hafta pay for that you know. This tiny ad agrees:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!