This week's book giveaways are in the Cloud and AI/ML forums.
We're giving away four copies each of Cloud Native Patterns and Natural Language Processing and have the authors on-line!
See this thread and this one for details.
Win a copy of Cloud Native PatternsE this week in the Cloud forum
or Natural Language Processing in the AI/ML forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Knute Snortum
  • Rob Spoor
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Piet Souris
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

[solved] updated Java to J6_31, now Tomcat 7 does not start from services

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

I had a look at the FAQ's regarding changing the JDK in catalina.bat,
but the Tomcat ver 7 on this server was installed by .exe and therefore does not have .bat files in the tomcat/bin directory.

I ran the tomcat7w.exe from /bin/ and the

1. Jvm path is pointing to the correct java path on the system:
C:\Program Files (x86)\Java\jre6\bin\client\jvm.dll

2. Java Classpath points to the same bin files (as these didnt change, just the java , well not changed, but updated)
C:\Program Files (x86)\Apache Software Foundation\Tomcat 7.0\bin\bootstrap.jar;C:\Program Files (x86)\Apache Software Foundation\Tomcat 7.0\bin\tomcat-juli.jar

3. Java Options just seem to point to Tomcat 7.0 folders.

After the java update I can no longer start tomcat from services, I get the error :
Error 1067: The process terminated unexpectedly.

Do I need to reinstall tomcat, or can I find a way to start the service?

Thanks

Edit : Solved
The user managed to screw up the java update of the JRE. A JRE reinstall fixed the problem.
 
Sheriff
Posts: 21774
103
Eclipse IDE Spring VI Editor Chrome Java Ubuntu Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for sharing the solution
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!