Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Spring MVC Portlet - session attribute required exception

 
Maria Laxmi
Ranch Hand
Posts: 40
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI,

I have a portlet developed using Spring MVC portlet. Recently we are seeing a lot of exceptions to get the command object from the session.
The exception is "Session attribute 'commondObjectName' required - not found in session".
We can not reproduce this in any of our local environments. This happens only in production. We can't find an exact test-case to reproduce it. Once we were able to reproduce it from FireFox browser but at the same time were not able to reproduce the same exception using other browsers (IE, chrome). One more thing, even if you see this exception in the log, nothing gets wrong on the page. The user experience is fine. It's just that the log file is getting cluttered with this exception and wants to get rid of it.

Does any one have any idea about this exception?

Thanks,
 
zrdegree Thakur
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maria Laxmi wrote:HI,

I have a portlet developed using Spring MVC portlet. Recently we are seeing a lot of exceptions to get the command object from the session.
The exception is "Session attribute 'commondObjectName' required - not found in session".
We can not reproduce this in any of our local environments. This happens only in production. We can't find an exact test-case to reproduce it. Once we were able to reproduce it from FireFox browser but at the same time were not able to reproduce the same exception using other browsers (IE, chrome). One more thing, even if you see this exception in the log, nothing gets wrong on the page. The user experience is fine. It's just that the log file is getting cluttered with this exception and wants to get rid of it.

Does any one have any idea about this exception?

Thanks,



I've the same setup, spring MVC portlet on liferay running on weblogic 10.3.5 and getting the same error "Session attribute ' ' required - not found in session"...I dont get this error if I choose to work with tomcat or weblogic 9.2.
Please help with the solution you have tried.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic