• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

remote machine clustering fails

 
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Friends,

I am trying to create clustering between two different machines on linux with glassfish 3.1.1.
I am able to create clustering on single machine but when it comes to
remote machine gives me error.I tried with GUI also but getting the same
error.

I am using one machine as DAS and created localnode and local instances
on DAS,then tried to create remotenode and instance on remote machine.

For Remote machine Steps:

1)create-node-ssh --nodehost <remotemachineip> node1 --port 14848
node is created successfully and reflect in domain.xml

2)list-nodes-ssh --long=true --port 14848
Getting list successfully

3)ping-node-ssh node1 --port 14848 -getting ping successfully

4)create-cluster --port 14848 --multicastaddress 228.9.3.1
--multicastport 2048 phmscluster

5)start-cluster --port 14848 testcluster

6)create-instance --cluster testcluster --node node1 --user admin
--host <remotemachineip> --port 14848 phmsinstance1

After step number 6 it gives me error:

Command failed on node node1 (remotehost): Could not contact the DAS running
at localhost.localdomain:14848. This could be because a firewall is blocking
the connection back to the DAS or because the DAS host is known by a
different name on the instance host localhost.localdomain. To change the
hostname that the DAS uses to identify itself please update the DAS
admin HTTP listener address.

Command _create-instance-filesystem failed

Please,Can any one help me?

Regards
Jatan
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic