This week's book giveaway is in the Agile forum.
We're giving away four copies of Fixing your Scrum and have Ryan Ripley & Todd Miller on-line!
See this thread for details.
Win a copy of Fixing your Scrum this week in the Agile forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Rob Spoor
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Junilu Lacar
  • Tim Cooke
Saloon Keepers:
  • Tim Holloway
  • Piet Souris
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Frits Walraven
  • Himai Minh

Running JForum on a headless linux box (no X)

Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Crunge,

thanks for your contribution. There is another post related to this subject. You can check at

[originally posted on by Rafael Steil]
Migrated From
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
This isn't really a bug in JForum so much as a potential bug in one's system setup. I wanted to run JForum on a linux box that has no X windows system on it. Unfortunately, JForum uses some X libraries to tinker with images. When trying to access a JForum page, I got an error similar to the following:

I dug around and managed to solve the problem on my own without having to install X on the machine. The general technique is found here:

In addition to the libs listed above, I needed the* libs. Once these files where copied to /usr/X11R6/lib/ dir on my server, I had to add the line:

in the /etc/ file of the server. That complete, I had to run as root.

The final step was to edit the configuration of how tomcat (my containter of choice) was started. On gentoo, I had to put the line:

in my /etc/conf.d/tomcat file. Other gentoo users might want to run as root. The important thing, regardless of your linux distro, is that the -Djava.awt.headless=true option makes it to the command that launches java (launching tomcat). You may have to edit your if your distro doesn't provide a simple way to pass options to tomcat.

Last but not least, I had to restart tomcat: and everything was peachy. Hope this helps others. BTW: this install is using postgres as the back end. The newest sql setup scripts worked like a charm.

[originally posted on by Anonymous]
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
    Bookmark Topic Watch Topic
  • New Topic