This week's book giveaway is in the Kotlin forum.
We're giving away four copies of Kotlin in Action and have Dmitry Jemerov & Svetlana Isakova on-line!
See this thread for details.
Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem with deploying JForum as a WAR into Tomcat 4.1.12  RSS feed

 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've hit a problem trying to deploy the JForum app as a WAR into Tomcat 4.1.12

When I open the starting page the following error occurs...



I've tried placing System.out logging messages into various places of the 'ActionServletRequest' and 'JForumCommonServlet' classes and these never get called.

Any ideas?



[originally posted on jforum.net by davout]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Instead of accessing "/JForumCA/forums/list.page", try just "/forums/list.page"

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I was using a starting URL of...



... that causes the error I reported earlier. (Note: I'm using 'JForumCA' as opposed to 'jforum' as this WAR is generated from a local variante that includes some fixes I've made to the 2.0.2. base).

If I use the shortened URI as you suggest...

... I get a 404 error

Might this be a class path or context path issue?



[originally posted on jforum.net by davout]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I found the answer... the WAR file was missng the *.sql files found under the 'config' folder.



[originally posted on jforum.net by davout]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
oooh.. indeed, they're very important ;)

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'd be interested to know why there absence isn't detected and reported as an error
[originally posted on jforum.net by davout]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That's a good question. In general, I am assuming the correct files will always be there. If they are not, it wasn't because some lack of the installer or something.

But, of course, I'm not trying to give an excuse. I aggree with you that this kind of stuff should be correctly handled.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!