Win a copy of Node.js Design Patterns: Design and implement production-grade Node.js applications using proven patterns and techniques this week in the Server-Side JavaScript and NodeJS forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

Error while registering

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm getting this error while registering. Is it because of X11?

<!-- BEGIN ERROR STACK TRACE <br /> java.lang.reflect.InvocationTargetException <br /> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) <br /> at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) <br /> at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) <br /> at java.lang.reflect.Method.invoke(Method.java:324) <br /> at net.jforum.Command.process(Command.java:106) <br /> at net.jforum.JForum.service(JForum.java:298) <br /> at javax.servlet.http.HttpServlet.service(HttpServlet.java:853) <br /> at jrun.servlet.ServletInvoker.invoke(ServletInvoker.java:91) <br /> at jrun.servlet.JRunInvokerChain.invokeNext(JRunInvokerChain.java:42) <br /> at jrun.servlet.JRunRequestDispatcher.invoke(JRunRequestDispatcher.java:257) <br /> at jrun.servlet.ServletEngineService.dispatch(ServletEngineService.java:541) <br /> at jrun.servlet.jrpp.JRunProxyService.invokeRunnable(JRunProxyService.java:204) <br /> at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(ThreadPool.java:426) <br /> at jrunx.scheduler.WorkerThread.run(WorkerThread.java:66) <br /> Caused by: com.octo.captcha.CaptchaException <br /> at com.octo.captcha.image.gimpy.GimpyFactory.getImageCaptcha(GimpyFactory.java:547) <br /> at com.octo.captcha.image.gimpy.GimpyFactory.getImageCaptcha(GimpyFactory.java:515) <br /> at com.octo.captcha.engine.image.ListImageCaptchaEngine.getNextImageCaptcha(ListImageCaptchaEngine.java:559) <br /> at net.jforum.entities.UserSession.createNewCaptcha(UserSession.java:347) <br /> at net.jforum.view.forum.UserAction.insert(UserAction.java:142) <br /> ... 14 more <br /> Caused by: java.lang.NoClassDefFoundError <br /> at java.lang.Class.forName0(Native Method) <br /> at java.lang.Class.forName(Class.java:141) <br /> at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:62) <br /> at com.octo.captcha.component.image.fontgenerator.RandomFontGenerator.getFont(RandomFontGenerator.java:496) <br /> at com.octo.captcha.component.image.fontgenerator.TwistedRandomFontGenerator.getFont(TwistedRandomFontGenerator.java:495) <br /> at com.octo.captcha.component.image.fontgenerator.TwistedAndShearedRandomFontGenerator.getFont(TwistedAndShearedRandomFontGenerator.java:494) <br /> at com.octo.captcha.component.image.wordtoimage.ComposedWordToImage.getFont(ComposedWordToImage.java:559) <br /> at com.octo.captcha.component.image.wordtoimage.AbstractWordToImage.getAttributedString(AbstractWordToImage.java:528) <br /> at com.octo.captcha.component.image.wordtoimage.AbstractWordToImage.getImage(AbstractWordToImage.java:512) <br /> at com.octo.captcha.image.gimpy.GimpyFactory.getImageCaptcha(GimpyFactory.java:544) <br /> ... 18 more <br /> <br /> END ERROR STACK TRACE-->
[originally posted on jforum.net by balakiran]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
HHmm. check if you have

jcaptcha-core-1.0-RC1.jar

and

jcaptcha-engine-1.0-RC1.jar

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Yes, both are in my: JForum-2.1.4/WEB-INF/lib/

What else could be the reason? Do you think they are not in the classpath? Do i have to explicitly add them to my classpath?
[originally posted on jforum.net by balakiran]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thank you, It worked now after moving to JRUN_HOME/lib. Somehow, it looks like jrun classpath is overriding jforum classpath setting. Now, i'm getting error related to X11.

"Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable."

Do i need to install X11 on this redhat linux machine?

[originally posted on jforum.net by balakiran]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
No, you don't need to have the files in the classpath. You can try to put into JRUN_HOME/lib, but I don't see how should it work.. but anyway, just give it a try.

If still it does not work, then I would suggest to disable captcha (Admin Panel -> Configurations -> Enable Captcha during registration).

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
No, you don't have to. Take a look in this topic:

https://coderanch.com/t/574500

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
i did not change anything, but i started getting this error. Any other jar files to move to: <JRUN_HOME>/lib?
<!-- BEGIN ERROR STACK TRACE <br /> java.lang.reflect.InvocationTargetException <br /> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) <br /> at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) <br /> at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) <br /> at java.lang.reflect.Method.invoke(Method.java:324) <br /> at net.jforum.Command.process(Command.java:106) <br /> at net.jforum.JForum.service(JForum.java:298) <br /> at javax.servlet.http.HttpServlet.service(HttpServlet.java:853) <br /> at jrun.servlet.ServletInvoker.invoke(ServletInvoker.java:91) <br /> at jrun.servlet.JRunInvokerChain.invokeNext(JRunInvokerChain.java:42) <br /> at jrun.servlet.JRunRequestDispatcher.invoke(JRunRequestDispatcher.java:257) <br /> at jrun.servlet.ServletEngineService.dispatch(ServletEngineService.java:541) <br /> at jrun.servlet.jrpp.JRunProxyService.invokeRunnable(JRunProxyService.java:204) <br /> at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(ThreadPool.java:426) <br /> at jrunx.scheduler.WorkerThread.run(WorkerThread.java:66) <br /> Caused by: java.lang.NoClassDefFoundError: com/octo/captcha/engine/image/ListImageCaptchaEngine <br /> at java.lang.ClassLoader.defineClass0(Native Method) <br /> at java.lang.ClassLoader.defineClass(ClassLoader.java:539) <br /> at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123) <br /> at jrunx.util.JRunURLClassLoader.defineClass(JRunURLClassLoader.java:187) <br /> at jrunx.util.JRunURLClassLoader.findClass(JRunURLClassLoader.java:152) <br /> at java.lang.ClassLoader.loadClass(ClassLoader.java:289) <br /> at jrunx.util.JRunURLClassLoader.loadClass(JRunURLClassLoader.java:77) <br /> at jrunx.util.JRunURLClassLoader.loadClass(JRunURLClassLoader.java:69) <br /> at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302) <br /> at net.jforum.entities.UserSession.createNewCaptcha(UserSession.java:347) <br /> at net.jforum.view.forum.UserAction.insert(UserAction.java:142) <br /> ... 14 more <br /> <br /> END ERROR STACK TRACE-->

[originally posted on jforum.net by balakiran]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
The problem is still with Captcha :



I don't know why you're getting these errors with JRun. But you always can disable Captcha.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
ok, what does "Captcha" do?
[originally posted on jforum.net by balakiran]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
wikipedia is your friend ;-)

http://en.wikipedia.org/wiki/Captcha

jforum is using it to prevent spamming.
[originally posted on jforum.net by marc]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I just downloaded JForum yesterday. I'm running it on Mac OS X 10.4.3, MySQL 4.1, Tomcat 5.0.28, Java 1.4. I am seeing the same problem. Disabling Captchca worked, but there is apparently something funky going on.

Tony
[originally posted on jforum.net by Tony Field]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am using Fedora 4 ,
JDK j2sdk1.4.2_09
and i am pretty sure i have put those jar files under $TOMCAT/common/lib/ and all the related paths. However it still prompts me the same error. And i have checked the log files and those JCaptcha files have been deployed already.

So i have no clue on what is going on. I even have tried to put the ehcache-1.2beta4.jar in tomcat's lib path but that wont help neither.

Sam
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi all,

I have found something silly about the java graphic packages in Fedora 4. The libXp.so is actually missing in the /urs/X11/lib path. So in order to fix that problem you have to download the deprecated libs from redhat's site.

Below is the link.

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/i386/xorg-x11-deprecated-libs-6.8.2-37.FC4.49.2.i386.rpm

Cheers,
Sam
[originally posted on jforum.net by samleong]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Nice information!!

Thanks Sam!

Rafael
[originally posted on jforum.net by Rafael Steil]
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic