Win a copy of Pro Spring MVC with WebFlux: Web Development in Spring Framework 5 and Spring Boot 2 this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Liutauras Vilda
Sheriffs:
  • Rob Spoor
  • Bear Bibeault
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh

Install on Jboss 3.2.7 and JDK 1.4.3 - Issue

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

Today i downloaded the jboss 3.2.7 and downloaded the jforum zip file and extracted the same in the deploy folder. But its giving the error while trying to start the jboss.

Packages waiting for a deployer:
org.jboss.deployment.DeploymentInfo@8d848be8 { url=file:/D:/jboss-3.2.7/server/default/deploy/JForum-2.1.4/ }
deployer: null
status: null
state: INIT_WAITING_DEPLOYER
watch: file:/D:/jboss-3.2.7/server/default/deploy/JForum-2.1.4/
lastDeployed: 1120271973452
lastModified: 1120271902490
mbeans:

Could you give a hint why this error is happening.

Thanks
--Vijay
[originally posted on jforum.net by vpandey]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Well, I personally don't have any experience with JBoss that may help to find the issue :\. Maybe another user of JForum does.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm doing the same thing here. Same error.
I expected to see a .war file in the download.
Think I may write a quick build script to package it into a *.war or *.ear so appservers can deploy. If I do I'll post here

[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
To anyone wanting to deploy to JBoss... (and who knows ant ;o)

This is a simple build script that will package and deploy to JBoss (or create a war suitable to deploy to a J2EE servlet container). Download the JForums, extract it to a folder, create a build.xml in the root with the following in it and modify the jboss.deploy.dir to point to your JBoss installation. Run it et voila.

Good luck
(I think they distribute this incorrectly - they should have a source distribution and a bin distribution not a jumble of both - just my humblke opinion)


[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Rafael Steil wrote:Well, I personally don't have any experience with JBoss that may help to find the issue



Errrr. There's JBoss code in the source (JBossCacheEngine imports org.jboss.cache.*)
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Anonymous wrote:

Rafael Steil wrote:Well, I personally don't have any experience with JBoss that may help to find the issue



Errrr. There's JBoss code in the source (JBossCacheEngine imports org.jboss.cache.*)



Well, that's JBossCache, which is only a lib

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Fair point (but it does come from the Jboss App Server code repository and pedantically speaking isn't a lib if in source format). But that's just a stupid discussion - your code is v nice to work with! Thanks
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hehehe. Thank you

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Works on JBoss 4.0 too. Thanks!
[originally posted on jforum.net by Anonymous]
 
I have a knack for fixing things like this ... um ... sorry ... here is a consilitory tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic