What error are you getting? I would guess that since you're trying this under both 1.4 and 1.5 you've got the Tomcat compatibility libraries installed. Try a fresh install of Tomcat without the compatibility libraries. Also, Tomcat 5.5 is on 5.5.15 - you've got a very old Tomcat. [originally posted on jforum.net by stdunbar]
1. All tests were made on the same system with the same MySQL.
2. A test with Tomcat 4, JDK 1.4.2_06 and MySQL 4.1 worked fine.
3. All tests with Tomcat 5.5.x and JDK 1.5.0_04 failed with the above error message.
4. I have not been able to test against Tomcat 5 and JDK 1.4.2_06, because I do not have the compatibility libraries installed. These are required to use Tomcat 5+ with a 1.4 JDK.
I will try to set up a test case for JForum 2.1.6, Tomcat 5 with compat. libs and JDK 1.4 later today and keep all of you posted.
Tom [originally posted on jforum.net by Anonymous]
I am using tomcat 5.5.4 without the compatibility libraries since it will only be started using a 1.5 JDK. And yes, I know the version is a little bit outdated. But for now I would really like to get this working, because upgrading the container on the production system might get me into other problems...
The error I get during the installation is:
I have tried the install on a freshly installed Tomcat 5.5.15 (current release) on the same system again using JDK 1.5.0_04 and it fails with the exact same error.
So I guess, it is really an issue with the JDK 1.5.0 update 4.
What do you think?
Tom [originally posted on jforum.net by karazon]