Win a copy of Node.js Design Patterns: Design and implement production-grade Node.js applications using proven patterns and techniques this week in the Server-Side JavaScript and NodeJS forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

Problems creating new categories

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hell´┐Ż? everybody, first i'd like to congratulate and thanks the developpers of this wonderfull software. I downloaded and installed jforum 2.1.6 running on websphere application server 5.1 using the hsqldb as db.
Everything seems to work fine except that in the administration pannel after i have created two more categories after the test one (Cat.A and Cat.B), i see only the test category and the Cat.A but not Cat.B (and also the forum i have created ander Cat.B don't show up). The same in the forum index i see as admin. As i connect as a simple user via http://myip/jforum i see everything right.
Thanks in advance for your attention and patience. I regret for my english sice i am italian speaking
[originally posted on jforum.net by suarez]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Try resaving all permissions:

Admin Panel -> Groups -> Permissions

Enter and click Save, even if you don't change anything.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Sorry if i am late responding to you but i have been out of the office in the last days.
Your suggestion works, but i also found out that when creating a new category if you highlight all the groups listed in the box, all things works fine, otherwise if no group or only one (me, i am still testing the application before open the forum to all our intranet, and have the 2 basic groups: admin and general) you have to re-save permissions every time.
Thanks again for your interesting job
[originally posted on jforum.net by suarez]
 
Villains always have antidotes. They're funny that way. Here's an antidote disguised as a tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic