Win a copy of Spring in Action (5th edition) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Knute Snortum
  • Junilu Lacar
  • paul wheaton
Saloon Keepers:
  • Ganesh Patekar
  • Frits Walraven
  • Tim Moores
  • Ron McLeod
  • Carey Brown
Bartenders:
  • Stephan van Hulst
  • salvin francis
  • Tim Holloway

Attach Files button has disappeared  RSS feed

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That's right. The button is gone. I have checked every persmission and configuration parameter.

Please help!!
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Not exactly sure why, but when I went to the admin control panel and moved persmissions back and forth for attachments the button came back.

FYI
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Attach Files button has disappeared ,I also met the problem, please help.
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
After you upgraded to a newer version of JForum? Then just re-save all permissions again, that it should work.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Brice -> The problem still the same with the last version, only the default forum has the attachement button ???
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
happening for me too on v2.1.6 ...only on new forums that I create while old ones still show that button. All within the same category (matter?)

anyway, I'll try that permissions toggling and saving thing.
[originally posted on jforum.net by ken0]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok, let me know the result.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
that worked.

in the same session when I create the forum, after I hit the update button on the forum admin page to create my forum, went to the group permissions page and visited the 2 groups I had specified for limited permissions (anonymous, general) and hit "save" on those pages (no changes) ...and that seems to have caused the "Attach Files" button to come back on new forums.

(I had created several forums, without this saving perms step, which always had that button missing).

cheers!
[originally posted on jforum.net by ken0]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
1. change [Allow download of existing Attachments] -> no

2. save

3. change [Allow download of existing Attachments] -> Yes

4. save

OK!! ^^

[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Anonymous wrote:1. change [Allow download of existing Attachments] -> no

2. save

3. change [Allow download of existing Attachments] -> Yes

4. save

OK!! ^^



The magic found by previous Anonymous is the key of universe!

Thank you.


[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Has a bug been logged for this behavior? I'm curious if it's fixed in the next release?
[originally posted on jforum.net by conquest]
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!