• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Devaka Cooray
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Jj Roberts
  • Al Hobbs
  • Piet Souris

I got a 500 error when uploading attachment

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi
I've been working successfully with Jforum (latest version) but when I try to upload a file I get the "internal server error". I haven't set any quotas for uploading by now. It only works when uploading small files (say, less than 100k).

Any ideas?

BY the way, where can I find the logs to check what is wrong, since I did not found any errors in the Tomcat's logs ?.

Thanks
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Me too

Have you found a solution to the problem yet? I will have a look today and let here know if I figure out something. I get following error:

HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

java.lang.NullPointerException
net.jforum.JForumExecutionContext.enableRollback(JForumExecutionContext.java:272)
net.jforum.JForum.service(JForum.java:209)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59)

note The full stack trace of the root cause is available in the Apache Tomcat/5.5.9 logs.


[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
that was me, Marcin
[originally posted on jforum.net by marcinn]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
We're working on that

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Please hurry up ... I will be fired
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Anonymous wrote:Please hurry up ... I will be fired



It's open source. If you're job is on the line you should fix it yourself.
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Anonymous wrote:Please hurry up ... I will be fired



Sorry, but I have my job too ;)

I have been pretty busy for the last past months, so I'm focusing on to get the bugs fixed and relase a new stable version, but it's hard to get all that work done almost alone.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Done, this bug is fixed.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
yup, built from cvs and replaced all class files on my previously v2.1.6 install and it now works.

BIG THANKS :!:
[originally posted on jforum.net by ken0]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Which java files were affected? I would like to add that fix without moving to the CVS version of JForum.
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
net/jforum/ActionServeltRequest.java

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I installed the CVS 2.1.6 build from May 3, 2006, and I can confirm that this bug is fixed.

I uploaded a 750K+ file with no issues, which didn't work previously.
[originally posted on jforum.net by GatorBait3]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Rafael Steil wrote:net/jforum/ActionServeltRequest.java

Rafael



Thanks
[originally posted on jforum.net by Anonymous]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Could I get the compiled class of the new net/jforum/ActionServletRequest.java? I really need it, and this computer does not want to compile anything for some reason.
[originally posted on jforum.net by Newtothis]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
YES, somebody, please the compiled class file! Thank you!
[originally posted on jforum.net by chandler]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I got the latest version of net/jforum/ActionServeltRequest.java and recompiled it against the source code from 2.1.6, which seemed to work fine.

I got a compiled class (or rather some compiled classes).

But when copying the new compiled class ( and its private classes ) to the tomcat server it got some strange hickups. Initially it ran just fine and I could indeed upload files. But after using the forum for a while it completely froze and I had to restart the tomcat to make it work again. This happens all the time, so I had to remove the compiled classes and reintroduce the old ones to get stable performance - but without the upload posibility :-(

Anybody - any comments clues !?!? Is there a dependency file that I need ?

Unfortunately I cannot get the latest source from cvs.dev.java.net since the firewall I�m behind blocks all trafick on port 2401. So I have to get all files one at a time from the web cvs GUI.... :-(
[originally posted on jforum.net by NPO]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hmmm - guess not :-(

Just have to wait for the 2.1.7 release.....
[originally posted on jforum.net by NPO]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Enjoy it!!!

[ ]'s
[originally posted on jforum.net by leandro_salvador]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanx a million. It seems to work fine now without the forum crashing.

:-)
[originally posted on jforum.net by NPO]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have the same problem, but i don't have this file in my CVS (downloaded last week).

What i do?

Thanks
[originally posted on jforum.net by Christopher Siqueira]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Create the directory "tmp" in the root of your context, and give it full write access.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have the directory tmp yet, but don't work.

You know if this is a really BUG?

If you help me, i will looking for this bug and commit for all, but i don't know much about this architecture/directories/class.

Thank and I will wait your answer.
[originally posted on jforum.net by Christopher Siqueira]
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic