• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Liutauras Vilda
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Piet Souris
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
Bartenders:
  • Himai Minh
  • Carey Brown
  • Frits Walraven

JBoss - log4j error

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am running JBoss 3.0.2 SP1 and am trying to install JForum 2.1.6?

I extracted the installation to a folder in the deploy directory named 'jforum.war' (so the autodeployer would detect and install it) and it seems to run but the log shows the follwing errors...





Looks like a jar version mismatch or configuration error for log4j?

Can anyone shed some light on this?

Thanks

Chris Parsons
[originally posted on jforum.net by cparsons]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
If JForum's log4j.xml is causing you problems, try removing it and see what happens (or something like that..)

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks, that was the conclusion I came to - I renamed the 'log4j-1.2.12.jar' file to 'log4j-1.2.12.old' and the problem disappeared...

There is a 'log4j.jar' library supplied as part of the JBoss installation, whether there is some problem with them co-existing?

Anyway, looks like it is working fine now

Regards

Chris Parsons
[originally posted on jforum.net by cparsons]
 
A feeble attempt to tell you about our stuff that makes us money
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic