• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

why i Audit the posts to moderate but i can't see it

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i Audit the posts at the Admin Control Panel ->Message Approving
at forum index i can see the post_subject but the post_text i cannot see
it show :The message you're trying to access is waiting for moderation. Cannot proceed.

who can tell me the err reason thinks:)
[originally posted on jforum.net by jyhcyd]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you a moderator for that forum?
[originally posted on jforum.net by GatorBait3]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i find the www/website/install.jsp thinks!
[originally posted on jforum.net by jyhcyd]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i audit the posts as Aprove

i set the Categories ->Moderate this Category yes
i set the Forums at this Categories -> Moderate this forum? yes

but i don't know why i audit the posts i can see the title of the post but i can't see content of the post ? s
[originally posted on jforum.net by jyhcyd]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
up
[originally posted on jforum.net by jyhcyd]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

jyhcyd wrote:i Audit the posts at the Admin Control Panel ->Message Approving
at forum index i can see the post_subject but the post_text i cannot see
it show :The message you're trying to access is waiting for moderation. Cannot proceed.

who can tell me the err reason thinks:)



//----------------------------------------------------
i use jforum version 2.1.6 i Audit the posts at forum index i can not see the post_subject and the post_text

i use jforum version 2.1.7 i Audit the posts at forum index i can see the post_subject but the post_text i cannot see
it show :The message you're trying to access is waiting for moderation. Cannot proceed.

why?
thanks!!

[originally posted on jforum.net by jyhcyd]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've tried this, and it works fine on my install (2.1.6 with May CVS updates).

After going to the forum with the new message, or in the Admin Console / Message Approving area, are you clicking on the "View" button at the far right to see the entire post before you approve it? Can you see the contents if you do that?

Then check the "approve" checkbox, and "submit" to finalize the approval (or "reject" .. the default setting of "defer" will leave the message in it's "waiting for moderation" state).

Are you doing these steps?
[originally posted on jforum.net by GatorBait3]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i download the Jforum 2.1.6 today at http://prdownloads.sourceforge.net/jforum/JForum-2.1.6-src.zip?download

in the Admin Console / Message Approving area, i clicking on the "View" button at the far right to see the entire post before i approve it, i Can see the contents !

Then i check the "approve" checkbox, and "submit" to finalize the approval .

but i return the jforum index but i can't see the contents
[originally posted on jforum.net by jyhcyd]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Could this be related to the other problems you're having with JForum and Oracle?

[originally posted on jforum.net by GatorBait3]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yes i use JForum with Oracle 9i
but i don't know wherefore ??
[originally posted on jforum.net by jyhcyd]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

jyhcyd wrote:yes i use JForum with Oracle 9i
but i don't know wherefore ??


Unfortunately, Oracle isn't one of the "out of the box" databases that JForum uses. You may have to do many alterations to get it to function properly.

[originally posted on jforum.net by GatorBait3]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
English Language

this problem has been solved !!
it's not JForum bug ! this problem resultingly Oracle jdbc driver wrong!!!

Jforum use Oracle jdbc driver : ojdbc14.jar (this driver is Oracle9.2 and higher edition)

but i use Oracle jdbc driver : ojdbc14.jar too it is problem causation !

i find this problem at :

GenericModerationDAO -> aprovePost() ->
public void aprovePost(int postId) throws Exception {
PreparedStatement p = JForumExecutionContext.getConnection().
prepareStatement(
SystemGlobals.getSql("ModerationModel.aprovePost"));
p.setTimestamp(1, new Timestamp(System.currentTimeMillis()));
p.setInt(2, postId);
p.executeUpdate();
p.close();
}


ModerationModel.aprovePost = UPDATE jforum_posts SET need_moderate = 0, post_time = ? WHERE post_id = ?

but after execute this SQL the need_moderate field not equal to "0" but need_moderate = -~

after i use Oracle9.0 Jdbc dirver(oracle12.jar) it is well

then this problem has been repaired!

use database dirver with you database edition!!

//----------------------------------------------------------------------------------

Chinese Language

��ԍ?�����Ѩ�����?��?�����?����?Ώ����?JForum�?�Ѩ����??��ξ��Oracle jdbc ����?��?�Ѩ����?�
JForum �?��Ӭ�?�Oracle jdbc ����?����ojdbc14.jar--Oracle9.2 �??�ȴ��?�����?㎩��?�
��ξ�Ԋ?��Ӭ�?㾥��?���Ҿ�� Oracle9.0 ��Ծݫ�?����JDBC����?��??�Ѩ�������??�?܏����?����??

��Ԍ?ԍ?��?�Ѩ����Ϭ�??�??
GenericModerationDAO -> aprovePost() ->
public void aprovePost(int postId) throws Exception {
PreparedStatement p = JForumExecutionContext.getConnection().
prepareStatement(
SystemGlobals.getSql("ModerationModel.aprovePost"));
p.setTimestamp(1, new Timestamp(System.currentTimeMillis()));
p.setInt(2, postId);
p.executeUpdate();
p.close();
}


ModerationModel.aprovePost = UPDATE jforum_posts SET need_moderate = 0, post_time = ? WHERE post_id = ?

�?Ҿ�Ծ䤏�Ό�Ώ����SQL�??need_moderate�?Ѿ���?��?��?�?䊼? "0" ��΍?䊼?" -~"������ۻ�?��?�?�??
�ݫ�?���?��ӎ���?��??�Ѩ�����������?����??

��?�??����ۍ�?�?�����??�?���?�??���?��Ӭ�໌᱾���?���ҍ����Œ�?��Ӎ?㎩��?��??



I love JForum !!!
[originally posted on jforum.net by jyhcyd]
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!