• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

JForum is not working with the IP address

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

koolnsmart wrote:Hi, I am using apache-tomcat-5.5.20 as a web server and mysql-5.0.18-2.1 as the backend for jforum in Fedora Core 5. When I use http://localhost:8080/jforum in firefox it is woking fine. I placed the complete directory of jforum from apache-tomcat-5.5.20/webapps to /var/www/html and I replaced all "localhost" entries with my IP address in jforum-custom.conf, located in /var/www/html/jforum/WEB-INF/config. But I cannot access this from using my IP address. Firefox is giving the error....

Not Found

The requested URL /jforum/forums/list.page was not found on this server.

I am new to web servers. Can any one advice me how to fix this?


This has nothing to do with using an IP ... but how you are trying to integrate the Java app in Apache! You can't just copy the java app files into the Apache html directory and have Apache serve the java app pages.

Do a search for jk_worker or Tomcat/Apache integration and set up the jk_worker file so that Apache knows to send the java app pages to the Tomcat app server. (after moving the JForum files back to where they were originally installed)
[originally posted on jforum.net by GatorBait3]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I am using apache-tomcat-5.5.20 as a web server and mysql-5.0.18-2.1 as the backend for jforum in Fedora Core 5. When I use http://localhost:8080/jforum in firefox it is woking fine. I placed the complete directory of jforum from apache-tomcat-5.5.20/webapps to /var/www/html and I replaced all "localhost" entries with my IP address in jforum-custom.conf, located in /var/www/html/jforum/WEB-INF/config. But I cannot access this from using my IP address. Firefox is giving the error....

Not Found

The requested URL /jforum/forums/list.page was not found on this server.



I am new to web servers. Can any one advice me how to fix this?
[originally posted on jforum.net by koolnsmart]
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!