• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

Default logging level too verbose

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I installed jForum 2.17 on resin 3.1.23 (RH 3) and see this message every second in the log:
21-Mar-2007 22:32:28 BEGIN check for expired resources. [com.mchange.v2.resourcepool.BasicResourcePool@413fc6]
21-Mar-2007 22:32:28 FINISHED check for expired resources. [com.mchange.v2.resourcepool.BasicResourcePool@413fc6]

Ok, I can work out its doing no harm except eating disk space but the problem is the logfile is shared with other webapps which need monitoring.
Am I correct in saying its just the default logging level, and if so where do I fix it please? Thanks

Update: I just realised I can add more info. There are other webapps, using log4j, which have set the level to DEBUG, on this server. So its possible on single installations this verbosity isn't seen and its just us which have triggered it. The usual fix (I'm told) is to use a file to override the defaults ("log.properties"?). Thats as much as I know - anyone know how to fix it please?
[originally posted on jforum.net by john.steel]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
A couple of possible items to try:

First, in the web.xml, find the jforum servlet definition and change the init-param development parameter to false (release zip has this set to true by default).

Next, is to look at the log4j.xml file in the WEB-INF directory and change all the priority tags to either info or warn. You may need to add a section like:

<category name="com.mchange">
<priority value="info"/>
<append-ref ref="jforum-stdout"/>
</category>

If those don't work, then you'll need to figure out where in Resin's classpath it's getting it's logging config from (e.g., a file named log4j.xml, log4j.properties, logging.properties, etc. is).

[originally posted on jforum.net by monroe]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

monroe wrote:
First, in the web.xml, find the jforum servlet definition and change the init-param development parameter to false (release zip has this set to true by default).



That was it! Thanks.
[originally posted on jforum.net by john.steel]
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic