Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Previous version download

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Where can I download previous versions from, specifically 2.1.7
Thanks - John Bush
[originally posted on jforum.net by John Bush]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
you can check them out from CVS and build them
[originally posted on jforum.net by Sid]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, you can get it from the CVS, branch B_2_1_7

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am attempting an upgrade from 2.1.6 to 2.1.7 to 2.1.8. I sync'd to the CVS label you indicated and did a build. So first things first. The PostgreSQL upgrade script gave me some errors:



Then, on starting 2.1.7 (Tomcat 5.5.15) I got a two errors:





I know, I know, I should have kept up with new versions but, well, I didn't Am I stuck on 2.1.6 forever now?

This is under PostgreSQL 8.1.10 / Linux / Sun JVM 1.6.0_03.
[originally posted on jforum.net by stdunbar]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I made an update from 2.1.7 to 2.1.8.

Most troubels i had was due to my custom template and custom language bundle files. Those are horrid to maintain as there were changes too.

Other than that i didnt face much troubels - fortunately. So i cant tell if there's more issues from 2.1.6 to 2.1.7

What you could do however is - if it tells you there's fields missing, try to check out the 2.1.6 or 2.1.7 create scripts. Somewhere the field definitely is defined and update the database manually and erase error by error.

Though it's best if you do a backup before ;) Just for sure

The errors you posted all look like database dependend errors. What I noticed too is that you use postgre. You could aswell check on the mysql update scripts and try to figure out differences . The mysql files most propably are updated best... as it's the most common used database ...
[originally posted on jforum.net by Sid]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Turns out that the real problem is that I don't know my own data server. I had an old database from the 2.1.4 days and, lo and behold, I can't upgrade that from 2.1.6 to 2.1.7. Sorry for the confusion - trying to get something done on a slow week and it turns out my brain is a bit slow too.
[originally posted on jforum.net by stdunbar]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I also need to upgrade from 2.1.6 to 2.1.8. You say I need to upgrade to 2.1.7 first, and to do this I have to build 2.1.7 from cvs first. Seeing as 2.1.7 is actually still needed coz you cant just upgrade from 2.1.6 to 2.1.8 it would be nice if you could maintain a link on the downloads page to the older versions to make the upgrade simpler please, dont you think ?




[originally posted on jforum.net by paultaylor]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
AFAIK, you don't need the full version of 2.1.7 to upgrade. All you need are the upgrade SQL scripts supplied in the upgrade folder of the 2.1.8 zip.

You run the 2.16 to 2.17 script and then run the 2.1.7 to 2.1.8 script. Then you're DB should be readable by the 2.1.8 code.


[originally posted on jforum.net by monroe]
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!