• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

[solved, thank you] Jforum and mod_rewrite

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi.

I have problems with jforum, combined with apache's mod_rewrite. I created a rewrite entry to change the URL from sub.domain.tld:8080 to an easier link - "forum" and "forum.domain.tld". This rewriting was successful but if i logout the URL changes back to the original-link "sub.domain.tld:8080". If i submit a posting the same effect happens and i loose my session. It happens at both rewrited URLs.

Has anyone an idea what happens when i submit the post or logout with my rewriting? At other rewritten webapps there is no problem such as this...

Greets


[originally posted on jforum.net by Windozer]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Which JForum version?

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm.. Can you try mod_proxy instead? I have been using it successfully like this:



In this case I have the forum on the root ("/") of the web application.

Rafael
[originally posted on jforum.net by Rafael Steil]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi.

I use JForum version 2.1.8.
[originally posted on jforum.net by Windozer]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Finally.... it works!

Best thanks.
[originally posted on jforum.net by Windozer]
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!