• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

Forums display

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

After installing JForum, I created groups, categories, forums, and users. However, when I access the forums page, I don't see forums and postings, unless I login as a user. After I login, I see the forums in the groups I belong to.

On the other hand, when I access the jforum.net forums page, I see all the categories / forums / postings without logging with the jforum.net user account.

Is it the way I have setup the forums and access permissions that's causing the problem?

Thanks
-- MH
[originally posted on jforum.net by mh]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You might want to have a look at your permissions set for the group "general". that's where the "anonymous users" are belonging to. It's most likely that 'general' does not have permission to see the forums. If no forum is visible in a categorie, the categorie is not rendered aswell.

On jforum.net all users have priviledge to read, but only registered users may write ...
[originally posted on jforum.net by Sid]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Sid wrote:You might want to have a look at your permissions set for the group "general". that's where the "anonymous users" are belonging to. It's most likely that 'general' does not have permission to see the forums. If no forum is visible in a categorie, the categorie is not rendered aswell.

On jforum.net all users have priviledge to read, but only registered users may write ...



Thank you very much for the tip. I had removed the "General" group.

I reinstalled the database, that automatically created the "General" group. I changed a couple of permissions for this group and now I can see all forums without logging in.

Thanks once again.

-- MH
[originally posted on jforum.net by mh]
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic