• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

Login Problem

 
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I have configured jforum-2.1.8, with apche, tomcat. I have modified the proprty (proxied.context.path) to forum.link variable to run in apache. In all the locations its working fine, but i am facing a problem with login, that is after giving user name and password session is not created. Please advice.

Thanks in advance.
[originally posted on jforum.net by rrkumar]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Most likely cause is that the Tomcat session cookie is not being associated with the web server URL. E.g., if Tomcat thinks it's name is localhost, it will issue a session cookie for localhost, but if the web server redirect was for foo.com... the browser will ignore the TC cookie.

Use the same domain on all references to keep this working.

FWIW, you might consider using the JK Connector mods instead of proxy commands. This is the preferred method of linking Tomcat to Apache and keeps a lot of problems like this from happening. See the Connectors section of the Tomcat.apache.org site for details.
[originally posted on jforum.net by monroe]
 
Migrated From Jforum.net
Ranch Hand
Posts: 17424
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have tried with all the changes you have suggested, but with the mod_jk configuration we were able to get the tomcat manager only. I have added a rewrite rule also, now I was able to get the application, but again we are getting the session problem.

Thanks.
[originally posted on jforum.net by rrkumar]
 
Aaaaaand ... we're on the march. Stylin. Get with it tiny ad.
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic