• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Passing attributes through HTTP request

 
Ryan White
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello, I'm relatively new to Struts and JSP and am having some difficulty figuring out my problem here. I am trying to pass attributes to a JSP from an Action Class. I'm following the example of existing code but there must be something that I forgot to change in order to make it work. I keep getting the following error:



Is there something in the struts-config file that needs to indicate that attributes are being passed? Like I said I have one ActionClass and JSP that work and I'm trying to add an additional page. I thought I duplicated all of the essential functionality but obviously I'm missing something.

 
Ryan White
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does anyone have any help on this? Or at least a direction to point me in?
 
Amirtharaj Chinnaraj
Ranch Hand
Posts: 241
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
you try to put the line above you have mentioned

<bean efine id="test" value="james"/>

i think you forgot to initilize the variable test

regards
amir

[ February 25, 2008: Message edited by: Amirtharaj Chinnaraj ]

[ February 25, 2008: Message edited by: Amirtharaj Chinnaraj ]
[ February 25, 2008: Message edited by: Amirtharaj Chinnaraj ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic