Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

umlat character problem  RSS feed

 
praveen kumar gowda
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i have database which consists of data which includes umlat characters...so when i fetch the data from the database and trying to display it on jsp,it is showing some different vaule,say for example,

Hardware prüfen

On internet explorer this displays as

Hardware prüfen

 
Tim Moores
Saloon Keeper
Posts: 3511
77
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Apparently the encoding isn't set correctly somewhere. Best practice these days is to use UTF-8 everywhere. Is the DB set to use that? Are you setting the Content-Type header in the JSP correctly?
 
praveen kumar gowda
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Tim,


is it required to set both DB and application side?
please let me know how to set ...
 
Tim Moores
Saloon Keeper
Posts: 3511
77
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, you need to handle it with the same encoding everywhere. Check the documentation of whichever DB you're using for how to do that. Generally, that needs to be done when the DB is first created.
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!